FUDforum
My FUDforum

Home »  » RocketPort » RocketPort Linux drivers 4.05 (They don't work with newest Linux kernel)
RocketPort Linux drivers 4.05 [message #962] Sat, 05 May 2018 09:11 Go to previous message
RockMod is currently offline  RockMod
Messages: 3
Registered: May 2018
Junior Member
I mean these drivers: rocketport-linux-4.05.tar.gz

I tried to compile them with newest 4.16.7 Linux kernel, but they are unusable with this newest version.

1. There occurs that "function implicitly declared" warning. This still can be overriden, and drivers can be compiled, anyway it's troublesome.

2. Unfortunately, even after successful compilation and installation these drivers are rejected by kernel - here are lines from syslog:

May 5 08:10:48 machine kernel: [ 23.169581] rocket: loading out-of-tree module taints kernel.
May 5 08:10:48 machine kernel: [ 23.169673] rocket: Unknown symbol setup_timer (err 0)
 
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Where is the 'setrocket' command?
Next Topic: FAQ - How do I verify the RocketPort modules are loaded?
Goto Forum:
  


Current Time: Wed Apr 08 09:15:53 CDT 2020

Total time taken to generate the page: 0.00709 seconds